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Abstract

This tutorial is a brief guide to getting started with Eclipse CDT IDE included in the Maxim ARM Cortex
Toolchain. This guide provides steps on how to create, import, build and debug a project using the
MAX3263X SDK.
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Introduction

This tutorial is a brief guide to getting started with Eclipse CDT IDE using the MAX3263X SDK included
in the Maxim ARM Cortex Toolchain. Eclipse is an integrated development environment (IDE) that
supports C and C++ language through the C/C++ Development Tooling (CDT) plugin. The MAX3263X
software development kit (SDK) includes the MAX3263X library, firmware examples and
documentation to help get users up and running on the MAX32630/31 ARM® Cortex® microcontroller.
This guide provides steps on how to create, import, build and debug a project in Eclipse using the
MAX3263X SDK.
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1  Create a Workspace

Open Eclipse by going to the Start Menu and navigating to the folder name specified during installation,
e.g., All Programs\Maxim Integrated. After displaying the splash screen, Eclipse asks for a workspace
location (Figure 1); the default workspace is usually sufficient. It is recommended not to select a

workspace in the Maxim Integrated installation directory, -e.g., C:\Maxim. Also, workspace paths with
spaces do not function properly in Eclipse.

i B

|| Select a workspace

Eclipse stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

Workspace: C:\Users\John.DoehDocuments\EclipseWorkspace - Browse...

[7] Use this as the default and do not ask again

ok || cancel

Figure 1. Eclipse Workspace Launcher.

Each time Eclipse opens, you are prompted to select a workspace location. Selecting a location creates
a workspace if one does not already exist. Select the Use this as the default and do not ask again
checkbox to bypass this prompt in the future. The first time a workspace is opened, a welcome window
appears. Close this welcome window to see the C/C++ workspace perspective.
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2 Import Example Projects

1. In Eclipse, right click in the Project Explorer area and select Import or go to File > Import
(Figure 2).

File Edit Source Refactor MNavigate 5S¢
RIS

[ Project Explorer 52 = 0

New 4

Import...
Export...

o L

Refresh F5

Figure 2. Import Project.

2. Onthe Import window under General, select Existing Projects into Workspace and click Next
(Figure 3).

Select

Create new projects from an archive file or directory,

Select an import source:

|typefilter text

4 [~ General
@‘ Archive File
|2 Existing Projects into Workspace |
[, File System
EL Preferences

B = C/Crs

[ = CVS

[ = Git

[ [ Install

[ = Remote Systems

[ = RPM

[+ = Run/Debug

[» [&= Tasks

[+ = Team
r 3 Trarinm

Figure 3. Select Import Source.
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3. Click the Browse button to select the Maxim directory
(C:\Maxim\Firmware\MAX3263X\Applications\EvKitExamples).

4. The projects should show up in the Projects list. Check the projects to import and then check
Copy projects into workspace under Options (Figure 4).

5. Click Finish.

6. The project should appear in the Project Explorer on the left. Refer to Build/Debug Project to run

the example.
< Import Lo [0
Import Projects —
Select a directory to search for existing Eclipse projects.

-

@ Select root directory:  C\Maxim'\Firmware\ MAX3263X\Applicatior -

() Select archive file: Browse...
Projects:

ADC (Ch\Maxim\Firmware\MAX3263 X0 Applications\EvKitExam » Select All

[C] AES (CAMaxim\Firmware\MAX3263X\Applications\ EvKitExamp
£ Deselect All

[[] CLEMAN_4MHz (C:\Maxim\Firmware\MAX3263X\Applications
[[] CRC (CAMaxim\Firmware\MAX3263X\Applications\EvKitExam
[ Hello_Warld (C\Maxim'\Firmware\MAX3263X\Applications\Ev =

|:| 12C_Loopback (CAMaxim'\Firmware\MAX3263X\ Applications\E
[ LP_GPIO (C:\Maxim\Firmware\MAX3 263\ Applications\EvKitE:
[T] LP_PMU (C:\Maxim\Firmware\MAX3263X0Applications\EvKitE: _

= im Ao s srrmmemin s

4 | i 3

Options

[ Search for nested projects

[¥] Copy projects into workspace
Working sets

[] Add project to working sets

Select...

@:‘ MNext = [ Finizh l ’ Cancel

Figure 4. Select Project to Import and Copy.
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3  Create New Project from Existing Project

The simplest way to start a new project is to copy an existing project containing all the proper settings
Follow the steps outlined in the sections below.

3.1 Copy/Rename Project

3.2 Import Project

3.1 Copy/Rename Project

Note: If an example project has already been imported into the workspace, close and restart
Eclipse before continuing.

To create a new project from an existing project, first copy the existing project into the new
workspace directory; one of the EV kit firmware examples provided in the Maxim directory, e.g.,
C:\Maxim\Firmware\MAX3263X\Applications\EvKitExamples, is copied in this example.
Then, rename the project folder to the desired project name (Figure 5).

' . ¥ Libraries » Documents » My Documents v EclipseWorkspace »
= ———— e ——

Fle Edit View Tools Help

Organize » i Open Share with +

E-mail Burn New folder
it Favorites — Documents library
B Desktop EclipseWorkspace
4 Downloads Mame -
= Recent Places

. .metadata
5 Libraries .. RemoteSystemsTempFiles
@ Documents | .. TemperatureRead
| My Decument:

IJ Public Docume = 4 [

m

b TemperatureRead Date medified: 11/18/2015 3:38 PM
] ! File folder

Figure 5. Project Folder Rename.

2.

Inside the project folder, delete the build folder and rename the *.launch file to the project name,
e.g., TemperatureRead.launch (Figure 6).

@‘C)-\ | « Documents » EclipseWorkspace » Temperaturel
File Edit View Tools Help

Organize v [ Open ~ Share with + E-mail Ne

0 Favorites B

B Desktop
18 Downloads

Documents library

TemperatureRead

B Name
%l Recent Places
#& OneDrive for Bus 1 settings
=) .cproject
A Libraries |E] .project
C
@ Documents =] mainc
& Music || Makefile
[E5] Pictures ‘ |7 TemperatureRead.launch
DB ©ybzarcion aal < |

m= TemperatureRead.launch Date modified: 4/12/2016 1:3¢
= ‘ LAUNCH File Size: 5.50 KB

Figure 6. Project Files.
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3. Open .cproject, .project and *.launch files in a text editor, and replace the old project name with
the new project name, e.g., Replace SPIM_MX25 with TemperatureRead.

3.2 Import Project

1. In Eclipse, right click on Project Explorer area, and select Import or go to File > Import
(Figure 7).

File Edit Source Refactor MNavigate 5S¢
i P TS R

[ Project Explorer 52 = 0

New 2

Import...

C. &

Export...

Refresh F5

£

Figure 7. Import Project.

2. Onthe Import window, under General select Existing Projects into Workspace and click Next

(Figure 8).
— ™
Select \
Create new projects from an archive file or directory, | g - El

Select an import source:

|typefilter text |

4 [~ General -
@‘ Archive File
|2 Existing Projects into Workspace |
[, File System
EL Preferences

= C/C++

[ 2= CVS

[ = Git

[ [ Install

[ = Remote Systems

[ = RPM

[+ = Run/Debug

[» [&= Tasks L

[ = Team
r 3 Trarinm

m

@ | <Back [ Net> [ Finsh  |[  Cancel

Figure 8. Select Import Source.
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3. If the new project is in the workspace directory, uncheck Copy projects into workspace. If the
new project is outside the workspace directory, check the Copy projects into workspace.

4. Select the project to import using the Browse button to select the project directory.
Note: If the project files were renamed correctly, the project should appear in the Projects box
with a checkmark. If you get an error saying the project already exists, uncheck Copy projects
into workspace, then click Refresh (Figure 9).

5. Click Finish.
i ™
Import Projects . .
Select a directory to search for existing Eclipse projects.

-

@ Select root directory:  C:h\UsersiJohn.Doe\Documents'\EclipseWork + l Browse... ;

() Select archive file: Browse...

Projects:

TemperatureRead (C\Users\John.Dog\Documnents\EclipseWork Select All

Deszelect All

Refresh

< | i 3

Options
[ Search for nested projects
[T] Copy projects into workspace
Working sets

[T Add project to working sets

Warking sets: Select...

@ Next > Einish || Cancel

Figure 9. Select Project to Import.
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4  Build/Debug Project

To build and debug a project in Eclipse, follow the steps outlined in the sections below.

4.1 Build Project
4.2 Debug Project

4.1 Build Project

Before a build, Eclipse can show errors of unresolved include paths and symbols. The project setting have
been set to find the include paths and symbols based on the Makefile output after a build. Before the
first build, right click on the project in the Project Explorer and select Clean Project. After the clean
completes, right-click on the project again and select Build Project or click the Build (hammer) icon.
Projects can have multiple build configurations shown in the Build icon drop-down (Figure 10).

Refactor Mavigate Search Pr

H- Rl LN

” v 1Debug i

Figure 10. Build Icon.

The Console window shows the progress of the build and the results. If the project builds successfully
the Console says Build Finished without any errors (Figure 11).

If there are source files in the project still showing errors of symbols that cannot be resolved, go to Project
> C/C++ Index > Freshen Files or Project > C/C++ Index > Rebuild. If neither of these work, go to
Troubleshooting Unresolved Symbols section.

[2: Problems o= Tasks El Console 52 | £ Properties EPRET | uH =H ||| B~ = 0

CDT Build Censole [TemperatureRead]
arm-none-eabl-gcc -mthumb -mcpu=cortex-md -mtloat-abi=sotttp -mipu=tpvd-sp-dle -Wa,-mimplicit-it=thumb -
arm-none-eabi-gcc -mthumb -mcpu=cortex-md4 -mfloat-abi=softfp -mfpu=fpvi-sp-di6 -Wa,-mimplicit-it=thumb -
arm-none-eabi-gcc -mthumb -mcpu=cortex-m4 -mfloat-abi=softfp -mfpu=fpva-sp-di6 -Wa,-mimplicit-it=thumb -
arm-nene-eabi-gcc -mthumb -mcpu=cortex-mé4 -mfloat-abi=softfp -mfpu=fpv4-sp-dl6é -Wa,-mimplicit-it=thumb -
arm-none-eabi-gcc -mthumb -mcpu=cortex-md4 -mfloat-abi=softfp -mfpu=fpwv4-sp-dl6 -Wa,-mimplicit-it=thumb -
arm-none-eabi-gcc -mthumb -mcpu=cortex-md4 -mfloat-abi=softfp -mfpu=fpvi-sp-di6 -Wa,-mimplicit-it=thumb -
arm-nene-eabi-gcc -mthumb -mcpu=cortex-mé4 -mfloat-abi=softfp -mfpu=fpv4-sp-dl6é -Wa,-mimplicit-it=thumb -
AS JC/Maxim/Firmware/MAX3263X/Libraries/CMSIS/Device/Maxim/MAX3263X,/ Source/GCC/ startup_max3263x.5
arm-none-eabi-gcc -mthumb -mcpu=cortex-md4 -mfloat-abi=softfp -mfpu=fpvi-sp-di6 -Wa,-mimplicit-it=thumb -
arm-nene-eabi-gcc -mthumb -mcpu=cortex-mé4 -mfloat-abi=softfp -mfpu=fpv4-sp-dl6é -Wa,-mimplicit-it=thumb -
LD /cfUsers/John.Doe/Documents/Eclipseborkspace/TemperatureRead/build/max3263x. elf

m

13:46:16 Build Finished (tock 95.317ms)

4 m 2

Figure 11. Console Window.
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4.2 Debug Project

There is a debug configuration for each sample project provided. To debug, click the drop down on the
bug icon and select Debug Configurations... (Figure 12).

i Window Help

Efi'ﬂ'(l'é‘*\|%5§@[5)@

= (no launch history)
=3
Debug As PRt (C
Debug Configurations...
Organize Favorites.., mai
@Brier 5P

* Sd_oe_ 2T ano.

Figure 12. Debug Drop-down.

From here, select the project name under the GDB OpenOCD Debugging category, e.g.,
TemperatureRead, and click Debug (Figure 13).

=

&

Create, manage, and run configurations

TEx B3k~

Name TemperatureRead

[type filter text

[] C/C++ Application
[E] C/C++ Attach to Application
[T] C/C++ Postmortem Debugger

Main %% Debugger] [ Startupw % Source| © gommoﬂ

C/C++ Application:
build/MAX3263x.eff

[] C/C++ Remote Application
[£] GDB Hardware Debugging

4 [T] GDEB Open0CD Debugging Broject:

Veriables.. | [Search Project...| [ Browse.. |

[[E] TemperatureRead|
¥ Launch Group

TemperatureRead

Build (if required) before launching

Browse...

Build configuration: [Debug

() Enable auto build
@ Use workspace settings

Select configuration using 'C/C++ Application’

() Disable auto build
Configure Workspace Settings...

Filter matched 8 of & items

[ mpply || Rever |

@

Figure 13. Debug Configurations Window.
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After a debug configuration is launched, it is added to the debug configuration launch history in the
Debug (bug) Icon drop-down (Figure 14).

vjﬁvﬂqujggffv
[c] 1TemperatureRead
[&] 2ExampleProject

.

Debug As *
Debug Configurations...

Organize Favorites...

Figure 14. Debug Drop-down.

Eclipse opens the Debug perspective automatically and attempts to build, load, and run the program. By
default, a breakpoint is set at the first line of main (Figure 15).

r Bl
File Edit Source Refactor Mavigate Search Project Run Window Help |
TS E e E s R i S s il s T O Qe R e O I
i Quick Access ‘ ﬁl B C/C++ | %5 Debug
%5 Debug i3 %% &1 | i+ ¥ =3 0= Variables 23 9 Breakpoi.. i} Registers Peripherals =4 Modules = O |
4 [E] TemperatureRead [GDE OpenOCD Debugging] ¥ ok | £ 9§ /§4| e v
a 18 MAX3263x.elf Mame T
4 o Thread [1] (Suspended : Breakpoint)
= . . (=)= error int
= main{) at main.c:71 0x19¢ & realDat MAXG1E55 dat
.a openocd [+ [= realData _data
s arm-none-eabi-gdb
4 (] 3
4 +
[£] main.c &2 [c]0x19¢ = 0 5= Outline 5% = O
gl e— / = cEERRY o % T
int main(void) o stdioh p
int error;| & stdinth
MAX31855 data realData; = string.h
El o mxc_config.h
f/initialize display =1 nhdl2832h
NHD12832_Init();
NHD12832_ShowString( (uints_t*)"MAX31855 Temperature”, @, 4); u MAX31.855.h
= tmr_utils.h
//initialize SPI talking to MAX31855 # SPLFREQ
error = MAX31855 Init(SPI_FREQ); ++  UpdateDisplay(MAX31855_da
Sl @ main(void) : int o
ifferrar 1= E NN ERRORY
I Lo T ————
] Console 52 - Tasks Problems Executables [J Memory m X &l Ex Eﬁ| =] | | #EB~-riy= 08
TemperatureRead [GDB OpenOCD Debugging] arm-none-eabi-gdb
The target endianness is set automatically (currently little endian) ~
Temporary breakpoint 1, main () at main.c:71 H
71 !
No breakpoint number 3.
4 G
Writable Smmart Insert 72:15

Figure 15. Debug Perspective.
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Breakpoints can be set by double-clicking next to the desired line on the blue vertical bar (Figure 16).

[ main.c 22
/*********************************************************************:
= int main(void)

1

int error;
MAX31855_data realData;

/finitialize display
NHD12832_ Init();
NHD12832_ ShowString((uintd_t*)"MAX31855 Temperature™, @, 4);

//initialize SPI talking to MAX31855
krror = MAX31855 Init(SPI_FREQ);

if(error !'= E_NO_ERROR)

{
NHD12832 ShowString((uints_t*)"Init Errer”, 1, 4);
MNHD12832_ShowString((uints_t*)"Restart Program”, 2, 4);
while(1){};

1

while(1)

I

Figure 16. Add Breakpoint.

There is a debugging toolbar shown in the Debug perspective that can be used to step through code
(Figure 17). The icons in this toolbar are (from left to right): Resume (F8), Suspend (disabled), Terminate
(Ctrl+F2), Disconnect (disabled), Step Into (F5), Step Over (F6), and Step Return (F7-disabled).

ctor Mavigate Search Proj
e B R

Figure 17. Debugging Toolbar.

The user can also manually switch between the Debug and C/C++ perspectives (Figure 18).

. TS 0 e

Quick Access ﬁ’| By C/C++
#E|FREICAA Y= O

Figure 18. Change Perspectives.
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5 Register View

Included in the Eclipse distribution is the Embedded Systems Register View (EmbSysRegView) plugin
that allows the user to view the Cortex Microcontroller Software Interface Standard System View
Description (CMSIS-SVD) file for the product being used (e.g., MAX32630). This file provides an
itemized listing of the product's registers. To configure the plugin in Eclipse, select Window >
Preferences. Under C/C++ > Debug select EmbSys Register View. In the drop-downs select the
following: SVD(CMSIS) for Architecture, MaximIntegrated for the Vendor, and MAX32630 for the

Chip. Click OK (Figure 19).

= Preferences

type filter text EmbSys Register View -

> General
4 C/C++
Appearance
> Autotools
> Build
Code Analysis
> Code Style
4 Debug
Breakpoint Actions

A Periperal Register View for embedded system

Chip description
] ARM 32-bit Cortex-M4 Microcontroller
-

Architecture:

[svb(cmsts)

Vendor:

’ Mazximintegrated - ]

Chip:
[maa2630 LY
Board:

Disassembly

> EmbSys Register Vie
Floating Point Mem
Source Lookup Patk
Traditional Mermory
> Editor
File Types

-- none ---

Indexer
Language Mappings
» Mew C/C++ Project Wi
> Profiling
> Property Pages Settings
Task Tags
Template Default Value
Changelog
> Help
> Install/Update
> Library Hover
> Mylyn
> Remote Systems
> Run/Debug
> Specfile Editor
> Team
Terminal
> Tracing
< I 3

Cancel

Figure 19. EmbSys Register View.
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To show the register view, select Window > Show View > Other... and under Debug select EmbSys
Registers and click OK (Figure 20).

= Show View o 2=

type filter text

4 = Debug B
©g Breakpoints
%5 Debug s

=27 Disassembly

B EmbSys Registers
{2 Executables

&1 Expressions

@ Memory

[@ Memory Browser
=i, Modules —
85 5 Resources

&, Peripherals

it Registers

m

=

5 Signals
2% Trace Control =~

[ ok || canca |

Figure 20. Show EmbSys Registers.
Groups can be expanded to show individual registers, and individual registers can be expanded to show

the bits contained. Double-click a register or bit to show the current value (Figure 21).

[l Console = Tasks (£ Problems 3 Executables [J Memory " EmbSys Registers 52
a Arch: SYD(CMSIS) Vendor: MaximIntegrated Chip: max32630 Board: --- none ---

Register Hex Bin Reset Access  Address Description
b= OWM 1-Wire Master Interface
4 [= ADC ADC/ AFE
a (= ADC ADC/ AFE
a CTRL 0x0000081E  00000000000000000000100000011110 0x00000000 RW  0x4001F000  ADC Control
E cpu_adc_start (bit 0} 00 0 Start ADC Conversion
E adc_pu (bit1) Ol 1 ADC Power Up
E buf_pu (bit 2) Ol 1 ADC Input Buffer Power Up
E adc_refbuf_pu (bit 3) Ol 1 ADC Reference Buffer Power Up
E adc_chgpump_pu (bit 4} Oecd 1 ADC Charge Pump Power Up
E buf_chop_dis (bit 5) O 0 ADCInput Buffer Chop Disable [INTERNAL USE ONLY]
E buf_pump_dis (bit 6) 00 a Disable Charge Pump Out to Input Buffer [INTERNAL ...
E buf_bypass (bit 7) 00 ) Bypass Input Buffer
E ade_refscl (bit 8) O 1] ADC Reference Scale
E adc_scale (bit 9) [ 1] ADC Scale
E adc_refsel (bit 10) ] 1] ADC Reference Select [INTERMAL USE OMLY]
E adc_clk_en (bit 11) Ol 1 ADC Clock Enable
E adc_chsel (bits 15-12) ] 0000 ADC Channel Select
E ade_xref (bit 16) 1] 1] Enable Use of ADC External Reference
E adc_dataalign (bit17) [ 1] ADC Data Alignment Select
E afe_pwr_up_dly (bits 31-24)  0x00 00000000 Delay from ADC Powerup Until ADC Ready Asserted
> STATUS 000000000 RW  0x4001F004  ADC Status
> DATA 000000000 RW  0x4001F008  ADC Qutput Data
> INTR 0x00000000 RW  0x4001F00C  ADC Interrupt Control Register
> LIMITO 000000000 RW  0x4001F010  ADC Limit0
S e e I S R

Figure 21. View Register and Bit Values.
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6 Add Header/Source Files to Project

To add more header/source files to a project, right click on the project and select New > Header File or

New > Source File (Figure 22).

= C/C++ - Temperafl

File Edit Source Refactor Mavigate Search Project Run  Window Help

BT [ - - e e sl T~ B [ @ i O A IS
[ Project Explorer 57 E|le Y= 08 [€ main.c 52 [¢] ioman.h ¢
4 ‘WNI 1 thermtiex = 1
3 &', Binari = CY Project.
1 B Archi Go Into |_<|> File ex
& ) Inclu .
b & build Open in New Window | File from Template err
; rm
3 @ main,) B Copy CtrleC [ﬁ Folder 3
5 Make
@ Ton] [ Paste CtlsV | @ Class
| Temp
= ¥ Delete Delete m‘f Header File
_ Remove from Context Ctrl+ Alt+Shift+ Down @‘} Source File
Source » | &% Source Folder Pt
Move.. C Project
Rename... F2 = .
C++ Project =
g mBy
£ | Import.. F% Other. Cirl+N
5 Export. T

Figure 22. Add New Header File to Project.

In the New Header (or Source) File window, keep the project folder as the Source folder and name the

file with *.h for header, or *.c for source file. Keep the Template as default (Figure 23).

Header File

Create a new header file,

Source folder:  TemperatureRead

Header filg: MAX31855.h

Template: Default C header template

v” Configure... ]

Figure 23. New Header File Window.
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To build the new source file with the project, the new source file should be added to the Makefile. Open
the Makefile, and add the new source file to SRCS (Figure 24).

# Source files for this test (add path to VPATH below)
SRCS = main.c
SRCS  += MAX31855.q]

Figure 24. Add Source file to Makefile.
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7  Create New Project from Scratch

To create a new blank project in Eclipse, follow the steps outlined in the sections below.

7.1 Create New ProjectError! Reference source not found.
7.2 Setup Debug Configuration
7.3 Add Files to Project

7.1 Create New Project

1. Select File > New > C Project.

2. Type in a project name and select Executable > Empty Project in the Project type, and Cross
ARM GCC in the Toolchains. Then click Next (Figure 25).

/| CProject —<)>
Create C project of selected type r H

Project name: ExampleProject

Use default location

Location: 7C:\Users\John.Doe\Documents\EclipseWorkspace\Exam Browse...
Choose file systern: | default ~
Project type: Toolchains:
b (= GNU Autotools | Cross ARMGCC! |
4 (= Executable Cross GCC
@ Empty Project Microsoft Visual C++

@ Hello World ANSI C Project
@ Hello World ARM C Project
> (& Shared Library
b (& Static Library
b (= Makefile project

Show project types and toolchains only if they are supported on the platform

@ [ emmad( e

Figure 25. New C Project.
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3. On the next window uncheck Release under Configurations, and open the Advanced settings...
(Figure 26).

F ™

Select Configurations —

Select platforms and configurations you wish to deploy on r

- —

Project type: Executable
Toolchains: Cross ARM GCC

Configurations:

& Debug;

Select all
B3 Release
Deselect all

Advanced settings...

Use "Advanced settings" button to edit project’s properties.

Additional configurations can be added after project creation.
Use "Manage configurations” buttons either on toolbar or on property pages.

@ [ <Back [ Net> || Enish  |[ Cancel

Figure 26. New Project Settings.
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4. Under C/C++ Build on the Builder Settings tab, deselect Use default build command, and
enter “make ECLIPSE=1" into the Build command field (Figure 27).

= Properties for ExampleProject = I@
type filter text C/C++ Build & o o
> Resource
Builders
. C/C++ Build Configuration: ’Debug [ Active ] M

. C/C++ General
Project References

Run/Debug Settings E Builder Settings | (@) Behaviour | Q§' Refresh Policy
» Task Repository
WikiText Builder
Builder type: External builder

[] Use default build command

Build command: make ECLIPSE=1

Makefile generation

[C] Generate Makefiles automatically Expand Env. Variable Refs in Makefiles

Build location

Build directory: | S{workspace_loc:/ExampleProject}

Workspace... ] ’ File system... ] [‘u’ariables... ]

’ Restore Defaults ] ’ Apply ]

@ [ ok || conca |

Figure 27. Project Properties-Build Settings.

5. Uncheck Generate Makefiles automatically and remove “/Debug” from the Build directory,
e.g., ${workspace_loc:/ExampleProject}).

6. Goto C/C++ General > Preprocessor Include Paths, Macros etc. and click on the Providers
tab. In the list, check CDT GCC Build Output Parser and change the Compiler command pattern
to “(.*gce)” (Figure 28).

7. Use the Move Up button to move CDT GCC Build Output Parser to be second in the list and
CDT GCC Built-In Complier Settings Cross ARM to be third in the list (Figure 28).
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= Properties for ExampleProject

type filter text

> Resource
Builders
» C/C++ Build
4 C/C++ General
> Code Analysis
Documentation
File Types
Formatter
Indexer
Language Mappings
Paths and Symbols
Preprocessor Include P:
Profiling Categories
Project References
Run/Debug Settings
» Task Repository
WikiText

1| T | +

@

Preprocessor Include Paths, Macros etc.

Configuration: ’Debug [ Active |

'] [Manage Configurations...

4= Providers

# CDT User Setting Entries

—/2CDT GCC Build Output Parser:

& CDT GCC Built-in Compiler Settings Cross ARM
EfExported Entries from Referenced Projects [ Shared |
2 CDT Managed Build Setting Entries [ Shared ]

[ ®, CDT Cross GCC Built-in Compiler Settings [ Shared |
[] ®, CDT GCC Built-in Compiler Settings [ Shared ]

[] @, CDT GCC Built-in Compiler Settings Cygwin [ Shared |
[ @, CDT GCC Built-in Compiler Settings MinGW [ Shared ]

Language Settings Provider Options

Compiler command pattern:  (*gecc)

Container to keep discovered entries

@ File (use when settings vary for different files)

() Folder (use when settings are the same for all files in each folder)

() Project (use when settings are the same for all files in the project)

Use heuristics to resolve paths

Clear Entries

Reset

Move Down

[7] Use global provider shared between projects [ Store entries in project settings folder

[ ok

’ Restore Defaults ] ’ Apply

)

Cancel

) {

)

Figure 28. Project Properties-Preprocessor Settings.

8. Select OK, Next >, and then Finish.

7.2 Setup Debug Configuration

1. To add a debug configuration for the new project, select Debug Configurations... from the

Debug icon drop-down (Figure 29).

i Window Help

PO A N

Rl Ne=a

- (no launch history)

3l

Debug As

Debug Configurations...

Organize Favorites...

mai

WETieT 5P1

® Ao T oo

Figure 29. Debug Icon Drop-Down.
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2. Right click on GDB OpenOCD Debugging and select New (Figure 30).

Create, , and run confi ti

DEx B3~

| type filter text

C/C++ Application
C/C++ Attach to Application
C/C++ Postmortem Debugger

C/C++ Remote Application
GDB Hardware Debugging
4 |[c] GDB OpenQCN Nehunaning |
[E] Temper [¥ MNew
= Launch Grg

Duplicate ¢
& Delete

Figure 30. New Debug Configuration.
3.

It is recommended to change the name of the debug configuration to match the project name.
Under the Main tab, type “build/MAX3263X.elf” in the C/C++ Application field (Figure 31).

Create, manage, and run configurations ﬁ\‘

EEEIEE N

Name: ExampleProject
[ type filter text

[E] C/C++ Application

Main %5 Debugger| B Startup| & Source| ] Common|

[£] C/C++ Attach to Application (€% = L=z

[£] C/C++ Postmortem Debugger

build/MAXG263x.<If
[E] C/C++ Remote Application
(5] 6D Hardware Bebugging Variables... | [SearchProject..| [ Browse.. |
4 [T] GDB OpenQCD Debugging Project:
[£] BampleProject ExampleProject Browse..
[£] TemperatureRead
& Lounch Group Build (if required] before launching
Build configuration: [Debug -]
Select configuration using 'C/C++ Application’
©) Enable auto build
@ Use workspace settings

() Disable aute build

Configure Workspace Settings...

Figure 31. Debug Configurations- Main Tab
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4. Under the Debugger tab, change the following (Figure 32):

OpenOCD Setup Executable: openocd
OpenOCD Setup Config Options: -s

${env_var.TOOLCHAIN_PATH}/share/openocd/scripts -f interface/ftdi/olimex-arm-usb-

tiny-h.cfg -f target/MAX3263X.cfg
GDB Client Setup Executable: arm-none-eabi-gdb
Delete the text in GDB Client Setup Commands

EEIEE;
type filter text
[€] C/C+~+ Applic

[£] C/C++ Postm

ExarnplePr
= Launch Group

Filter matched 8 of 8 it:

@

[€] C/C++ Attach to Application

<= Debug Configurations

Create, manage, and run configurations

Mame: ExampleProject

[El Main | % Debugger . I+ Startup| B Source| E| Commaon
ation OpenOCD Setup

Start OpenOCD locally
ortem Debugger

[] C/C++ Remote Application Executable: openocd
[] GDB Hardware Debugging
4 [€] GDB Open0CD Debugging

GDB port: 3333

oject Telnet port: 4444

Config options: - §fenv varTOOLCHAIN_PATH}/share/openocd/scripts -f interface/ftdi/olimex-arm-usb-tiny-h.cfg -f target/MAX3263X.cfg -

Allocate console for OpenQCD
GDE Client Setup
Executable: arm-none-eabi-gdb

Other options:

Commands:

Remote Target
Host name or IP address: | localhost

Port number 3333

[ Force thread list update on suspend

ems

Browse... | | Variables...

Allocate consale for the telnet connection

Apply

m

Revert

Debug

| [ close

Figure 32. Debug Configurations - Debugger Tab.
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5. Go to the Startup tab and deselect Enabled ARM semihosting (Figure 33).

I Create,

ge, and run g

Debug Configurations

REEIEE

Name:  EBxampleProject

ype filter text

[€] C/C++ Application
[T] C/C++ Attach to Application
[£] C/C++ Postmortem Debugger
[£] C/C++ Remote Application
[£] GDB Hardware Debugging
4 [] GDB OpenOCD Debugging
[E] BxamplePraject
[t] TemperatureRead
[ Launch Group

Filter matched 2 of 10 items

Main (# Debugger (’ Startup Ey Source| =1 Qommon}

Initialization Commands
[¥]Initial Reset. Type: init

[] Enable ARM semihosting.

Load Symbols and Executable
Load symbols
lse project binary: MAX3263x.elf

© Usefile: \ | [ workspace... | [ File System...
Symbols offset (hex):
Load executable
Ise project binary:  MAX3263x.elf
) Usefile: [ | [ Workspace... | [ File System... =

Executable offset (hex):

Runtime Options

Debug in RAM
Run/Restart Commands
Pre-run/Restart reset.

Type: halt  (always executed at Restart)

[#] Set breakpoint at: main
[¥] Continue

[] Set program counter at (hex): I:I

Restore defaults —

Apply Revert

@

Figure 33. Debug Configurations - Startup Tab.
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6. Under the Common tab, select the Shared file radio button and check the Debug checkbox
under Display in the favorites menu (Figure 34).

ﬁg Deb;g Configuratiol
|| Create, and run config i ﬁ
CERExX B83F- Name: E pleProject
| (& Main | %5 Debugger l B Startup | 5 Source [ e=| Qammor:\’.

[€] C/C++ Application s

[€] C/C++ Attach to Application ® Localfile

[€] C/C++ Postmortem Debugger

[€] C/C++ Remote Application © Shared file: \ExampleProject Browse.

[C] GDB Hardware Debugging 7 3 5 =

4 [E] GDB OpenOCD Debugging Display in favorites menu Encodlng ) )
[©] ExampleProject [¥] %5 Debug ©) Default - inherited (Cp1252)
TemperatureRead @ Other | 150-8859-1 v

@ Launch Group
Standard Input and Output
Allocate console (necessary for input)
[ File: ‘

[ Workspace... | [ Fite System... | [ Variables... |
_| Append

Launch in background

N B Apply Revert

Filter matched 9 of 10 items 4
@ [ Debug ] [ Close

Figure 34. Debug Configuration - Common Tab.

7. Click Apply, then Close. The project should now very closely match the provided example
projects.

7.3 Add Files to Project
1. Add a main.c source file to the project by right-clicking on the project, and go to New > Source
file.
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2. Ensure the correct Project folder is selected and name the file main.c (Figure 35).
Note: If you choose a different name, the Makefile must also be changed.

Source File A
Create a new source file. c
Source folder:  ExampleProject Browse...
Source file: main.q

Template: [Defauh C source template v] [ Configure... ]
@ [ Finish ][ Cancel

Figure 35. New Source File Window.

3. Leave the Template as Default C source template and click Finish. The new file should appear
in the Project Explorer.

4. The easiest way to create a Makefile is to copy the one used in the EV kit examples. Go to the
Maxim directory, e.g., C:\Maxim\Firmware\MAX3263X\Applications\EvKitExamples, and
locate the Makefile used in one of the EV kit examples. If using USB or BTLE copy the Makefile
from the USB or BTLE EV kit example.

5. Copy and paste the Makefile into the project directory (Figure 36).

' "
%I . ¢ Libraries » Documents » EclipseWorkspace » ExampleProject »

File Edit View Tools Help

Organize ~ _| Open Share with « E-mail Burn Mew folder
5 Favorites Documents library
Bl Desktop ExampleProject
.‘, Downloads Name -
“Zl Recent Places
. .settings
- Libraries 8] cpraject
— .
@ Documents B/ project
o Music <] main.c
[E=] Pictures | L_| Makefile

L Sukwarsinn

Figure 36. Copy/Paste Makefile.
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6. To see the Makefile in the Project Explorer in Eclipse, right click on the project and select
Refresh.

7. Open the Makefile and ensure the source file name matches the name picked above in step 2. If
there are additional files listed as source files that are not in the project, remove them (Figure 37).

# Socurce files for this test (add path to VPATH below)
SRCS = main.c

Figure 37. Makefile Source Files.
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8 Troubleshooting Unresolved Symbols

The EV kit examples are setup to discover the Maxim library include paths from the output of the
Makefile in the project. After a successful build the source files should not have any unresolved include
paths or symbols. If the source files are still showing unresolved errors, verify the project is setup to
discover the include paths by checking if the source files have a key symbol on the icon in the project
explorer (Figure 38).

» E‘T rnain.c

Figure 38. Source file with Key on Icon

If the source file(s) do have a key symbol try the following:

e Right click on the project and select Clean Project, then start a build.

e Goto Project > C/C++ Index > Freshen Files or Project > C/C++ Index >Rebuild

e Try starting a new workspace and import the project in with Copy Project into Workspace
checked (Figure 4).

e Try adding the include file paths into the project properties. See Add Include Paths to Project

If the source file(s) do not have the key symbol try the following:

e Check if the project properties are setup to discover the include paths. Right click on the project
and go to Properties. Go to C/C++ General > Preprocessor Include Paths, Macros etc. and
on the Entries tab verify CDT GCC Build Output Parser is second in the list. If it is not follow
steps 6-8 in Create New Project section. Then perform a clean and build on the project.

e Try adding the include file paths into the project properties. See Add Include Paths to Project

8.1 Add Include Paths to Project

The Maxim library include paths can be added to the project properties without having to discover them
from a build. This can be done manually by adding all eleven include paths, or by export/importing an
xml file with all the paths.

8.1.1 Manually Add Include Paths

1. Right click on the project in the Project Explorer and select Properties.

2. Go to C/C++ General > Paths and Symbols and on the Includes tab select GNU C
under languages (Figure 39).
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l
:

r -
Py —

Paths and Symbols T T
. Resource
Builders

s C/Cos Build Configuration: | Debug [ Active] = | [Manage Configurations...

4 C/C++ General
. Code Analysis

Documen tation (2 Includes [ # Symbols | =i Libraries | (% Library Paths | (2 Source Location | (= Output Location | 5] References
File Types
Formatter Languages Include directories Add...
Indlexer Assembly (%! S{MAXIM_PATH)/Firmware/MAX3263x/Libraries/Boards/Include
Language Mappings GNU C (=1 $(MAXIM_PATH)/Firmware/MAX3263x/Libraries/Boards/EvKit V1/Include
Ef:::;("ﬁiz?ﬂlﬂ;e N [ ${MAXIM_PATH}/Firmware/MAX3263x/Libraries/MAX3263XPeriphDriver/Include I
Prfine Catetorios (5 ${MAXIM_PATH)/Firmware/MAX3263x/Libraries/FreeRTOS/Source/include
g -ee (= $(MAXIM_PATH)/Firmware/MAX3263x/Libraries/CMSIS/Device/Maxim/MAX3263X/Include L

Project References
(= §(MAXIM_PATH)/Firm

(1= ${MAXIM_PATH)/Firm;

e/MAX3263x/Libraries/CMSIS/Include
€/MAX3263x/Libraries/MAXUSB/include/core/arm Maove Up

WikiTest (= ${MAXIM_PATH/Firmware/MAX3263x/Libraries/MAXUSB/include/core oD
(5 ${MAXIM_PATH)/Firmware/MAX3263x/libraries/MAXUSB/include/enumerate
(= ${MAXIM_PATH}/Firmware/MAX3263x/Libraries/MAXUSB/include/devclass
(% $(MAXIM_PATH}/Firmware/MAX3263x/Libraries/ MAXUSB/include
reprocessor Include Paths, Macros etc.” property page may define additional entries

@ p Include Paths, M . define additional entri

7] Show built-in values

[ =% import settings...| | % Bxport Settings..

® |

Figure 39. Add Include Paths.

3. Add all the library include paths here by clicking Add. See Include Paths for list of paths.
Note: These settings can also be imported by clicking Import Settings... and selecting a
previously saved .xml settings file. See Export/Import Include Paths for details.

4. Oncealltheinclude paths are added, click OK to save the changes and close the window.
Note: If there are source files in the project still showing errors of symbols that cannot be
resolved, go to Project > C/C++ Index > Freshen Files.

Include Paths:

F{MAXIM_PATH}/Firmware/MAX3263X/Libraries/Boards/Include
F{MAXIM_PATH}/Firmware/MAX3263X/Libraries/Boards/EvKit_V1/Include
${MAXIM_PATH3}/Firmware/MAX3263X/Libraries/MAX3263XPeriphDriver/Include
F{MAXIM_PATH}/Firmware/MAX3263X/Libraries/FreeRTOS/Source/include
F{MAXIM_PATH}/Firmware/MAX3263X/Libraries/CMSIS/Device/Maxim/MAX3263X/Include
F{MAXIM_PATH}/Firmware/MAX3263X/Libraries/CMSIS/Include
F{MAXIM_PATH}/Firmware/MAX3263X/Libraries/MAXUSB/include/core/arm
F{MAXIM_PATH}/Firmware/MAX3263X/Libraries/MAXUSB/include/core
FS{MAXIM_PATH}/Firmware/MAX3263X/Libraries/MAXUSB/include/enumerate
${MAXIM_PATH}/Firmware/MAX3263X/Libraries/MAXUSB/include/devclass
F{MAXIM_PATH}/Firmware/MAX3263X/Libraries/MAXUSB/include

8.1.2 Export/Import Include Paths

1. Import an example project with the include paths settings already added. See Import
Example Projects for more details.
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2. Right click on the example project in the Project Explorer and go to Properties.

3. Go to C/C++ General > Paths and Symbols and on the Includes tab click Export
Settings...

4. Select the project to export and check Include Paths (Figure 40).

= Export

Export
Export C/C++ project settings for use in another workspace

Select Project Select Configuration

= ExampleProject 3] Debug (Active)
=5 SPIM_MX25
= TemperatureRead

Export to file

Browse...

Cancel

Figure 40. Export Include Paths Window.

5. Click Browse to select the file location and name, then click Finish.
6. Click OK to close the project properties.
7. Onthe new project, right click and go to Properties.

8. Go to C/C++ General > Paths and Symbols and on the Includes tab click Import
Settings...
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9. Navigate to the .xml files created by the export and select the new project and check
Include Paths (Figure 41).

Settings file

C:\Users\John.Doe\Documents\EclipseWorkspace\includePaths.xml

Select Project Select Configuration

= ExampleProject 23] Debug (Active)
=5 TemperatureRead

Select settings to import
(= Include Paths

[ Finish ][ Concel

Figure 41. Import Include Paths Window.

10. Click Finish. Verify the GNU C include paths are the same as Include Paths.
Note: If there are source files in the project still showing errors of symbols that cannot be
resolved, go to Project > C/C++ Index > Freshen All Files.
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9 Trademarks

ARM is a registered trademark and registered service mark of ARM Limited.
Cortex is a registered trademark of ARM Limited.
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applications, or technology described is intended to suggest possible uses and may be superseded. MAXIM
INTEGRATED PRODUCTS, INC. DOES NOT ASSUME LIABILITY FOR OR PROVIDE A REPRESENTATION OF
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mechanical engineering or registered trademarks of Maxim Integrated Products, Inc. All other product or service names
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